What's new in GlobalProtect 6.0

Updated User Interface

Below are screenshots of both versions for you to compare.

New version 6.0

Not connected
Connected

Previous version 5.2

Supported Operating Systems

As older operating systems are retired from the developer, applications like GlobalProtect will remove support for them as well. A full list of compatible operating systems is available here: https://docs.paloaltonetworks.com/compatibility-matrix/globalprotect/where-can-i-install-the-globalprotect-app

Operating systems added

  • macOS 14 (Sonoma)

  • Windows 11

Operating systems retired

  • macOS 10.14 (Mojave)

  • Windows 8.1

Operating systems that are unsupported do not meet the Minimum Security Standards for Networked Devices Policy and may not be connected to the UNW network, including the use of the GlobalProtect VPN.